Phone System Outage

Incident Report for Xpress Bill Pay - Status

Resolved

This incident had been resolved. We and the vendor we use apologize for this issue.
Posted Oct 15, 2025 - 17:37 MDT

Identified

Our phone system provider is currently experiencing a disruption affecting both inbound and outbound calls. For support, please contact us via email at support@xpressbillpay.com.
Posted Oct 15, 2025 - 13:38 MDT
This incident affected: Customer Service (Support Telephone System).