Unsettled reports is blank

Incident Report for Xpress Bill Pay - Status

Resolved

No further issues.
Posted Sep 04, 2026 - 15:38 MDT

Monitoring

Reports are now online. We will be monitoring the fix to ensure performance remains at normal levels.
Posted Sep 04, 2026 - 09:06 MDT

Identified

We have identified an issue with the backend causing reports to be unavailable.
Posted Sep 04, 2026 - 08:50 MDT
This incident affected: Xpress Bill Pay (Xpress Bill Pay Administrative Site).