We will be performing Network Maintenance Friday 5-29 from 10:00 PM to Midnight. We expect minimal impact to the availability of services.
Posted May 28, 2026 - 09:26 MDT
Update
A fix is in place and we are continuing to Monitor.
Posted May 11, 2026 - 11:31 MDT
Update
We are continuing to investigate this issue.
Posted May 08, 2026 - 23:34 MDT
Update
We will be implementing a firmware fix on a network device at 9:00 PM MDT. Sites will be down for a short period of time while we work though the update.
Posted May 08, 2026 - 20:42 MDT
Update
We are continuing to investigate this issue.
Posted May 08, 2026 - 20:40 MDT
Update
Our team is continuing to investigate and monitor. A possible mitigation is in place.
Posted May 08, 2026 - 14:24 MDT
Update
Our engineering team is continuing to investigate.
Posted May 08, 2026 - 13:27 MDT
Investigating
We are getting reports and seeing an intermittent connection issue to the Xpress Bill Pay Sites.
We are investigating the problem and will provide updates as they are available.
Posted May 08, 2026 - 10:41 MDT
This incident affects: Xpress Bill Pay (Xpress Bill Pay Site, Xpress Bill Pay Administrative Site), Xpress Bill Pay API's (SimplePay API, SecureAPI, WebAPI), and Xpress Bill Pay Mobile App.